ZTree.com  | ZEN  | About...  

 Index   Back

Try /MAX:-1:-2   [Bug]

By: Martijn Coppoolse   Homepage   Voorburg, NL  
Date: Feb 09,2021 at 11:37
In Response to: Try /MAX:-1:-2 (Ben Kent)

> > > > I start every time Ztree with full screen (with switch - /MAX,
> > > > full startup params are /XT /MAX /APIT /OD /SD /ZM)
> > >
> > > See if any difference if you also use /Y

I’ve encountered the same problem; mostly at work, but also once or twice at home. I’ve never been able to pinpoint what caused it (nor have I tried really hard either; it’s usually easier to just open a new instance and get on with my day). I’ve had a nagging suspicion it could be related to my multimonitor setup, since Windows itself occasionally gets confused, and moves windows from one monitor to another after (un)locking the desktop — it sometimes leaves the window where it was, but moves the corresponding taskbar button to another monitor.

I’ve added /Y to my existing startup params too (/ZB /TOZV /APIT /ZM).

> Sounds to me like the window size is slightly too big at /MAX, so when
> the access denied error comes, the window gets redrawn at a smaller size,
> and on your system that trips something up.

I've got my config set to MAX-1 and MAX-2 at work, and still got the problem Zdneek mentions. Though my three monitors each have different DPI settings; and that’s also something several apps have trouble with (including Windows itself, e.g. the start menu will sometimes appear with enormously large letters on my low-DPI screen, or minuscule letters on my 4K monitor). So it could still be related to sizing.


> ZTree shouldn't quit on an Access Denied.
> Have you tried without /APIT?

/APIT shouldn’t have any effect on Alt-F7, should it?


> Try with this /MAX:-1:-2, it's what I have been using for years, I do
> it in the config.
> I found that without that setting, the ZTree window would be redrawn
> with scrollbars on unlocking, and a double Alt-F7 would be needed to get
> back. With the new console in Win10 with the wrapping text, I expect the
> redrawn window would have wrapped text, so appearing corrupted.

There’s no visual corruption, since the window actually disappears. All I see is a ZTW64.exe process that’s running at 100% on a single core, but has no (visible) window associated with it.


> Other things to try
> Call a shortcut (.lnk) file from Autohotkey, I use a shortcut to get
> the icon I like.

So do I.

> Call via a shell, i.e. cmd.exe /c ztw64.exe ...
> Change the default console font
> Switch to "Legacy Console mode"

For now, I’ll wait to see if the /Y trick works (or Microsoft fixes something in the console host).


--
Martijn

116 views      
 

Messages in this Thread

 
95,371 Postings in 12,032 Threads, 350 registered users, 29 users online (1 registered, 28 guests)
Index | Admin contact |   Forum Time: May 6, 2021 - 1:27 pm UTC  |  Hits:39,347,809  (7,713 Today )
RSS Feed